Technical Requirements

Alexis -

Desktop version is designed to work with the following:

  • Internet Explorer 8.0 or higher (Optimal performance is with latest IE available due to advertiser compatibility requirements)
  • Firefox 4.0 (and higher)
  • Chrome
  • Safari
  • Javascript (latest version required)
  • Cookies enabled (required)
  • Flash Player (latest version required)
  • Allow Pop-ups

Please see your own computer Help sections for free upgrades and downloads

 

Have more questions? Submit a request

Comments

Powered by Zendesk